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Account Plus .
& Complete Expense Management System.

AccountPlus

User Guide

Version 2.0.0.0

Note:

AccountPlus is an Open Source application for shared expense management. Users are free to modify
the source code as well functionality as per their need. Even individual components of account plus may
also be used feely.

For any query or feedback leave a comment to

http://aktripathi.wordpress.com/category/open-source/accountplus/

Or drop a mail to ak.tripathi@yahoo.com with subject line as AccountPlus
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1. Pre-Requisites

To run Account Plus, the target machine should have,

AccountPlus | User Guide

> Microsoft .NET Framework 2.0. To download the version, click the link below:
http://www.microsoft.com/downloads/details.aspx?FamilylD=0856eacb-4362-4b0d-

8edd- aab15c5e04f5&displaylang=en

> Acrobat Reader. To download the version, click the link below:

http://get.adobe.com/reader/

» Any of the following database
i.

il.

iii.

iv.

MS Access
SQL Server
My Sql
Oracle
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2. AccountPlus Overview

2.1 Introduction

AccountPlus is an application which can be used for shared account/expense management with
proper reporting and general analytics.

In order to justify the significance of AccountPlus, we should compare the traditional account
management system (paper based account management) with the features of AccountPlus.

Paper Based Account Management: Many times, it happens that multiple people share their daily
expenditures. To maintain all these accounts, usually we use paper to keep track of all the individual
expenses.

Drawbacks of Paper Based Account Management System

= At the end of the month, it involves a tedious calculation to find out who had expensed
what, and how much amount someone is either supposed to pay or got from others.

= Another major drawback of paper based account management system is that we won't be
able to analyze on which item our expense is increasing so that we can control the same.

= Paper based Account Management system has some security flaws like someone can very
easily alter the expenses entered by others.

Like this, there are many disadvantages of paper based account management. But with the help of
AccountPlus, at every instant we are capable of analyzing the expenses and doing the proper kind of
analysis to have a better control on expenditure with full security.

2.2 User Roles and their Rights

AccountPlus has two user roles,

1. Admin : Admin is the super user for the application who is mainly responsible for
a. Creating/ modifying the user details to access the system.
b. Finalizing the expenses.

2. General User: General user is the user who accesses the system very frequently. General users
are responsible for,

a. Add/ Update/ Delete the expenses. (User can’t edit or delete expense of other users)

b. Generating and analyzing the expenses.
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Working with AccountPlus

3. Login
Provide the User name and password and click on ‘Login’ button to login into the application.

If you are selecting ‘Remember me’ then for next time application will automatically populate
Username and Password.

.".,‘.
AccountPlus z.o.0.0
A Complete Expense Management System.

Logon Information

Click on info button to know the last log on information.

AccountPlus zo00
A Complete Expense Management System.
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4. User Management

User management i.e. adding new users and modifying user details right is reserved for the admin user

role only.

4.1 Creating new user

Login to the application as an admin user role,

1. Press ‘ALT+U’ or Go to File=> Add-> User

B AccountPlus 2.0.0.0

—

Add Pl Item Al+1
Switch User alt+3hift+R, m Iser Ak
Log OFf Ak +3hifk+-

2. A new window would appear. Select the desired user role and enter the user details. Click

on ‘Add’ button to create user.

2 Create Mew User

Uszertame | Firsthlame LastMame
admir Admin Adrnin Admin

testuser] User Test | Userl

hakile

testuzers Test Usger2 testadmin

ashish User  Ashish Tripathi k tripathi@ysho.. 3830346821

testadmin testadmin testadmin testadmin

e i E e nEwnec NEwrec

a Azhlizh u]

< ||

EREEEEE

€
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4.2 Searching any user
Press ‘ALT+U’ or go to File >Add->User. Into the window opened enter any of the details and click on
search button.

Note: All the fields are not mandatory you may enter any of the details to search.

4.3 Editing user information

‘ALT+U’ or go to File >Add->User. Select the user from the grid whose information you want to edit.
Selection of any row containing user information will make the user details available to the upper area
where details may be changed. Click on ‘Update’ button to save the changes.

% Create Mew User,

User ] 1 testuser]
Test Lz 5 Li=zer1
ak tripathig@yahoo.com ohile Q550946521

] At

Uzertlames | Firsthames | Lasthame hakile

| &dmin Admmin

| testuser

4.4 De activating user

‘ALT+U’ or go to File >Add->User. Select the user from the grid want to deactivate. Selection of any
row containing user information will make the user details available to the upper area. Uncheck the
‘Active’ check box and click on ‘Update’ button to save the changes.

4.5 Activating user

‘ALT+U’ or go to File >Add->User. Select the user from the grid want to activate. Check the ‘Active’
check box and click on ‘Update’ button to save the changes.
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5. Item Management

Item management i.e. adding new item and modifying item details right is given to all the user roles.

5.1 Creating new Item
1. Press ‘ALT+I’ or Go to File-> Add-> Item

# AccountPlus 2.0.0.0

Item Alk+1
Switch User Alt+5hifk+R, User AlE4L
Lag Off AlE+Shift+

2. A new window would appear. Enter the item details. Click on ‘Add’ button to create new
item.

ltem

[tem Mame Dezcnption |zdctive

| Mizcellaneaus Thiz item code iz used for M.

Eeneraﬂmusa‘l’ml& itém.ﬁdf:..

General house hold item edi...

5.2 Searching an item

Press ‘ALT+I’ or go to File >Add->Item. Into the window opened enter any of the details and click on
search button.

Note: All the fields are not mandatory you may enter any of the details to search.
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5.3 Editing item details

Press ‘ALT+U’ or go to File >Add->User. Select the user from the grid whose information you want to
edit. Selection of any row containing user information will make the user details available to the upper
area where details may be changed. Click on ‘Update’ button to save the changes.

ltem

General house hold item edited. I

[tem Mame Dezcnption |zdctive |

[t :
Mizcelaneous | Thiz item code iz used for M. |

| General houze hold item edi...
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6. Expense Management

Only general users can add, update or delete the expenses. Admin can’t enter any expense. Users can
edit or delete only their own expenses not other user’s expenses but can view all the users expense.

6.1 Adding new expense

Select the item against which you want to enter the expense. Selection of item will automatically
populate the expense description where as user can change the same. Enter other information like

amount and date. Click on the ‘Add’ button to save the changes.

Bill. Rent i~

Haouse rent paid aor general hills like
news paper, hrodband and
telephone etc,

28 Aug 2009 e

Once item is added successfully, newly added expense details would appear into the expense details

grid shown right side of the screen.

Note: Expense date can’t be greater than today’s date.

6.2 Editing expense details

Select the particular expense from the grid needs to be edited. Selection of any row containing expense
details will make the e details available to the left side of the screen where details may be edited. Click

on ‘Update’ button to save the changes.

Bill Rent o~

Details

LPG

House rent paid or general hills like
news paper, hrodhand and
telephone etc.

4000

28 Aug 2009 i

| General house fi... (110

House rent paid .
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6.3 Deleting expense

Select the particular expense from the grid needs to be deleted. Selection of any row containing expense
details will make the details available to the left side of the screen where details may be edited or
deleted. Click on ‘Delete’ button to delete the expense.

Billh Rent w Details Amount E:penseq By Date

LPG Test 07 Aug 2009

+| House rent paid or general bills like - = =
news paper, brodhand and "ater General houze h... |10 Test
telephone etc. | Bill Rert Houze rert paid . 4000

4000 . AccountPlus [15]
2B AU0 2008 v 5 ? } Are you sure you want ko delete the expense of INR [Rs.] 4000 entered for Bl Rent?

L ‘r’es_“ Mo ]

7. Reports

Reporting is the most exciting part of AccountPlus. AccountPlus has mainly three reports:
Expense Report
Monthly Report

Analytic Report

onthly Report
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7.1 Expense Report

Press F4 or click on the button present on tool bar to open expense report.

Once item is added successfully, newly added expense details would appear into the expense details
grid shown right side of the screen.

Expense Report

| Has Paid

Expense Report gives us the information about the
e Total expense in the tenor.
o Number of persons sharing the expense.
e How much is the expense for each one. (Individual Contribution)

Based on these three pieces of information, AccountPlus calculates “How much each user has paid, and
how much each participant is either supposed to pay to others participants or supposed to get from
other participants”.
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7.2 Monthly Report

Press F5 or click on the button present on tool bar to open monthly report.

Select the Month, Year for which report needs to be generated and click on ‘Generate’ button. Apart
from the expense details this report will give the information about some other important things like
Finalization Date, Total Expense and Days etc.

Monthwise Report

— —
Monthwise Report |i|

|® o '

hemMame | Expense
1

hizcellansous
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7.3 Analytic Report

Press F6 or click on the button present on tool bar to open analytic report.

Select the Month, Year for which report needs to be generated and click on ‘Generate’ button.

Analytic Report

| Trend1 | Aug (Pres.) | Trend2

1=1

“wegetables

restiem |

Testitem
T

| Trend2

Same as Monthly report, Analytic Report also has two views Individual and Monthly.

Whenever we are generating the Analytic Report for a particular Month and Year, the Analytic Engine of
AccountPlus checks whether expense data exists for the previous and next month data for the selected
month and year. If data exists, Analytic Report will give the trend on a particular item or user about
whether the expense has increased or decreased from the previous or next month.

Example

Suppose you have selected Dec, 2007 to generate the analytic report. Now, the Analytic Engine of
AccountPlus will check whether the data exists for Nov, 2007 and Jan, 2008. If the data exists, then
Analytic Report will compare the expense on each item or expense by users based on the view selected
(Individual or Item wise). If data for previous month does not exist then Analytic Report will compare only
the selected month and the next month.
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8. Finalizing expense

Only admin user role has got the rights to finalize the expenses.

In order to understand the Finalization process, we will take the example of paper based account
management system. In paper based account management system, at the end of the month, all the
expenses occurred needs to be summed up, to calculate the total expense for the month. Then divide
the total expense by number of persons supposed to share the expense. Like this, individual
contribution is calculated. Now all the members will either receive an amount by another member or

pay the amount to other members based on individual contribution and amount paid by each
participant.

Once this process is completed, expense sheet needs to be tear up or to be cross marked.

Finalizing the expense in AccountPlus is the same process where admin makes sure that all the users
have cleared their dues i.e. each participant have received or paid their dues. After finalizing the
expense, current expense details would not be displayed on the home page but the data will remain in
the database for analysis and reporting purposes.

How to finalize the expense?

Login as admin.
e Press F4 to generate the expense report.

e Click on Finalize button.

Expense Report

| Has Paid

121

[
o |
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Expense report provides information about total expense and the dues for the particular tenor. Pay/Get
is very important information in order to clear the dues, this information gives the information among
the users about who is supposed to pay and who is supposed to get.

9. Edit user profile

Press ‘Alt+P’ or go to Edit-> Profile to bring the screen where user profile can be edited.

2 Profile

ak tripathic@gmail.com

i [9530946521

How to change password?

Check the check box ‘Change Password’. Enter old password, password and confirm passwords field s
and click on ‘Submit’ button to save the details.
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10. Database information

[}
Sain

Alt+5hift+5

Database

Diagnioskics Alk+Shift+0

Calculatar Alb+C
Mokepad Alk+r
Calendar Alk+L

Press ‘Alt+Shift+S’ or go to Tools—> Database to open the database information window.

Database Information

Note:
e Only admin user role has got rights to back up the database.

e Current version supports backup operation for MS Access database only.
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11. System diagnostics

Press ‘Alt+Shift+D’ or go to Tools—> Diagnostics to open the diagnostics information window where
application logs and trace can be viewed.

Diagnostic

17 -Aug-2009 txd
1G-Aug-2009 txt
20-Aug-2009 txt
21-Aug-2009 txd
24-A00-2009 tx
25-Aug-2009 txt

e Select the Log or Trace radio buttons to view Log or Trace files. Double click to open the file.

e Export button may be used to export the Log/ Trace files.

12. Version information
Press F2 or go to Help—~> About to open the about dialog box.

About AccountPlus

Account Plus
A Complete Expense Management System.

AccountPlus iz a complete expense management system which helps in tracking
the shared expenses.
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13. Report a bug or contact author

Press F3 or go to Help~> Contact Admin to open window which helps the user to post their feed back or
comments to the author.

ContactAdmin

scoount Plus Bug Report

e Select appropriate option e.g. Report Bug, Feature request etc
e Enter the message into the message text area.

e Click ‘Send using Outlook’ to post the message to admin using Microsoft Outlook.
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